New ULP with Enterprise Connections only and no HRD: how to get rid of email input field?

I use the New ULP with Enterprise Connections only but no HRD (Home Realm Discovery), so I show the buttons at the bottom.
Since I don’t use a database connection and no HRD either, how to get rid of the email input box?

Does it require customizing the New ULP templates, or is there any config that I might’ve missed?

IIRC, this hasn’t been like this with the New ULP and Enterprise Connections in the past. I think it came in with the recent changes & config options around ID first?

Hi @mathiasconradt,

You can use the allowedConnections settings in Universal Login > Login by turning on customization and changing the allowedConnections value to be an array of your connections.

I’ll have to research this. I’m not sure if this feature release affected whether the email field shows up by default. I will let you know what I find out!

Just to double check, do you have “Identifier + Password” selected or “Identifier First” in your New ULP settings?

@stephanie.chamblee

I have ID First activated (right option), because with ID+Pwd, it won’t even work if I have no database connection enabled. I would get an error “No connection enabled for this client.”

I’m aware of the allowedConnections param, but I don’t think it solves the problem; also, note that allowedConnections is only applicable to Lock.js / Classic ULP, not New ULP, which I’m using.

Universal Login > Login by turning on customization

^ This refers to Classic ULP, not New ULP.

I also looked at https://auth0.com/docs/universal-login/new-experience/universal-login-page-templates but don’t see a way to just remove the email input field.

I just tried selecting ID+Pwd with database connections disabled and I see social/enterprise buttons only. Have you tried that config since the update?

1 Like

Hm, you’re right. I probably messed it up when playing around with the Classic/New ULP settings and the new options for ID and ID+Pwd. The mentioned error (No connection configured for this client.) I think only came up with Classic ULP then… anyway, you’re right, with ID+Pwd selected, it’s now as expected. Thanks for your help.

1 Like

Great! Glad that is working now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.