Enterprise Connection Azure AD - Do not show email field on Login/Signup


I successfully added an enterprise connection with Azure AD. It is working. But on the login screen there is now a email field, which I don’t want. It has something to do with the enterprise connection. How can I hide or disable it?

Thanks in advance!

Hi Martin,

Welcome to Auth0 Community!

From the screenshot you provided, it looks like you have Identifier First enabled as the Authentication Profile setting for New Universal Login. With this setting enabled, the email field will still appear on the login page even if there is no Database connection enabled for the application.

To remove the email field, you can first make sure you have no Database connections enabled for the application, and then go to Dashboard > Authentication > Authentication Profile and just switch the Authentication Profile to “Identifier + Password”.

Hope this helps!



Dear Dave,

yes, that did the trick. After changing the Authentication Profile to “Identifier + Password” the email field was gone in the signup dialog.

Thank you very much!


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.