M2M can't invite users to organizations


I’m trying to send an invitation with the management API but receive a 400 response saying: “The specified client_id does not allow organizations.”

Every other API call I tried with this M2M client ID works well (create org, create user, add membership).

This issue has been around for a long time (last post from January here)

How is it that this is still not resolved??? And if it is resolved, why is it failing now?

@dev43 I think you might be referring to the client_id that is required as part of the POST body when using the POST Invitations Endpoint. If that is the case, when inviting a user to an organization, you need to specify the client_id of an interactive (SPA, Regular Web App) application. This would be the application that you are inviting a user to use. Otherwise, if you had multiple applications served from your Auth0 tenant, there would be no way to know which one you want the user to see when accepting the Organization invitation. See: Invite Organization Members

Thanks for answering @adam.housman

Could you have a look at my other inquiry as it’s blocking our implementation of Auth0 and we did not receive a response yet?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.