Lock js 11 - Web - Autofill password not working on chrome IOS

Hello,

If you try to use lock (the modal) in chrome IOS, when you type the username field it let you choose from a list of user/password as usual.

If you type one, it will blink and the user and password field will stay blank.

Works fine on safari.

Anyway I can fix this ?

I tried with autocomplete on or off without success.

Regards,

3 Likes

Hey @kaltenf, is this solved for you meanwhile?
I am having similar issues during the last days…

regards
jens

@kaltenf @pododesk-operations Would it be possible to provide a snippet of code from your authentication request (remove any sensitive information)? And is this on Lock v11.9.1 ?

1 Like

Hey Kim, thanks for you offer to support. As I am not a developer I would need to ask you for some support on how to gather what you asked for :slight_smile:
Thanks, Jens

hey @kimcodes, can you help me to provide you with what you asked for?

@pododesk-operations yes! Please feel free to direct message me and we can pass the information through there!

1 Like

Hi!
I have same problem with auth0js. Autofill is not working on iOS (both Chrome and Safari) and my customer isn’t happy about that.
This is my code:

signInWithEmail() {
    let webAuth = new Auth0.WebAuth({
      ...environment.auth0,
      responseType: "id_token token",
    });
    webAuth.popup.authorize({
      connection: "Username-Password-Authentication",
      scope: "openid profile email",
      owp: true
    }, (err, authResult) => {
      if(authResult) {
        console.log(authResult);
      }
      if(err) {
        console.log(err)
      }
    });
  }

Have I done something wrong? And how to fix it?
(*) I tried to log into auth0.com and autofill did not work also.

Hey @chaupv!

Have you checked our docs on allowing autocomplete in Lock?

What you probably need to do is to set the allowAutocomplete value to true in your options variable and pass it as below:

var lock = new Auth0Lock(someParameter, someOtherParameter, options); 

Let me know if that was the root cause!

Hey @konrad.sopala!

Thank you for your response!

Since I have to customize “Login With Facebook/Google account” buttons, I used Auth0.js (v9) instead of Lock. I changed my code to use Lock as your suggestion this morning, but autofill is still not working.
This is my code:

signInWithEmail() {
    let options = {
      allowAutocomplete: true,
      allowedConnections: ['Username-Password-Authentication'],
      autoclose: true,
      auth: {
        responseType: "id_token token",
        connection: "Username-Password-Authentication",
        scope: "openid profile email",
        redirect: false
      }
    }

    let lock = new Auth0Lock(environment.auth0.clientID, environment.auth0.domain, options);
    lock.on("authenticated", (authResult) => {
      console.log(authResult);
    })
    lock.show();
  }

My account appeared on top of the keyboard but It had not been filled in the login form when I selected

Hi!
I think i’ve got the same issue since we upgrade auth0 lock from 11.0.1 to 11.12.1.
We use splash to emulate client navigation and use javascript to fill login and password.
On submit all field are reseted.

if it can help !

best regards

Hey,
I have added the allowAutocomplete: true to our lock configuration but still the credentials are always wiped out from the iput fields when submitting or switching from email to password.

Is there anything else I can do?

Jens

Hey there!

Sorry for such delay in response but it’s quite busy out here and we have limited bandwidth as of now. Terribly sorry and thanks for understanding!

I did some research and it seems like there were also other users having problem with this when updating their Lock version. I pinged repo maintainers about that and they asked me if you can open appropriate issue in the repo so they can get into this.

Thank you!

Any update on this? Would be happy with any workaround as this is pretty annoying for my users.

Hey there @swaraj!

Sorry for such a long delay in response. Have you guys tried this option from Lock?

- allowPasswordAutocomplete {Boolean}: Determines whether the password field will allow autocomplete; setting this to true is required for password manager support and to avoid many cases of adverse behavior. Defaults to false.