Irrelevant error in signup API

Found a irrelevant error while signup user using Authentication API. I mistakenly type “http” instead of “https” but the error i got is “Missing required property: connection”. This error actually comes when we miss connection fields in request payload.
Im attaching screenshot for further clarification.

1 Like

Thanks for reporting this. I was able to reproduce. I’ll report it internally.

Hi, just wanted to give you a quick update. Engineering has done initial assessment and determined that potential fix might be a breaking change but it is a low priority issue. It’s been added to the backlog and will be fixed later. For now our recommendation is to keep using https protocol.

Thanks for response. I just want to make you guys aware of this issue. Because its misleading when you are beginner at auth0

Was there a solution for this issue? I am getting the same error event though I clearly have the connection property set in my request body.

In my case my issue was not setting the “Content-Type” header to “application/json”. As soon as I did that, the error went away and the api endpoint I was trying to use ( worked correctly.