Error when calling /dbconnections/signup api

We tried to make this call: https://cmq-dev.auth0.com/dbconnections/signup

We get an error 400 with the follow msg: error: "Missing required property: connection"

Here the parameters:

"email":"ababa@test.ca",
"password":"asdeqwhjgadsjfklh323",
"connection":"Username-Password-Authentication","responseType":"token"}```

This problem started yesterday. We have been using this call more the 2 years.

Hey there!

Let me check if there were any changes to this endpoint. Have you changed anything else with that in the meantime maybe?

Non, I did not change anything.

Thanks a lot for providing that info! I’ll get back to you soon!

We continue with the same problem. @konrad.sopala. Do you have any suggestion for this?

Was this ever solved? We are having the same situation. No code changes, but all of a sudden we are getting “error”: “Missing required property: connection” when we try to create an account.

Is there an answer?

1 Like

I am getting the same. Please help!

I am facing this error in recent days. Could anyone help?

Let me reach out to our engineering team to find out whether something changed regarding this endpoint!

1 Like

Cool, thank you. My signup form was working before but all of the sudden started getting the error above. Now I’m receiving a XMLHTTPREquest CORS error, followed by an error message:

“Request has been terminated
Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc.”

Though when I use the Lock signup, everything works so I don’t believe it’s an issue with my settings.

Thank you for providing that context! I will relay that to our engineering team.

Are you including a content type header in your request (Content-Type: application/json)?

No, I haven’t. Should I be? and what should it be set at?

Exactly what I wrote above :slight_smile: You need to specify a format of the content that you’re gonna receive.

You can check how it’s structured using our Postman collections: