iOS error on hard device - login page not rendering in default browser

Hello,

I have auth0 implemented in both my Android and iOS app.

No issues running on simulator however, when executing this call/method in my dependency service: var loginResult = await auth0Client.LoginAsync(); it opens the native browser on the device but does not fully render the login page.

While fixing a different issue, I added this to the info.plist
LSSupportsOpeningDocumentsInPlace = yes

I then found that that allows the login to fully render in the native browser, however, the login fails with this error:

Name: NSInternalInconsistencyException Reason: Application has LSSupportsOpeningDocumentsInPlace key, but doesn’t implement application:openURL:options: on delegate

The loginResult NEVER gets back to the call in the dependency service but does when on simulator.

I THINK that the Auth0Client needs to be amended/fixed for this.
As I said, this all works in any iOS simulator. Just NOT on an actual device.

More Info:
If I implement an override for the openURL method in the AppDelegate, this NEVER gets hit in the simulator, breakpoint never reached, however, it always gets hit when debugging on actual device.

Can some please suggest how to fix this as it renders the app login useless.

Thanks

Just thought I’d better post in here - this issue is solved.

The older iOS version wasn’t handling the return/callback from Auth0.
AND, the openURL needs to be overridden in the AppDelegate in the iOS project.

I’ll try regressing on previous iOS version in emulators to see the min version.

But it is actually solved and done.

1 Like

Glad to hear that! Thanks for letting us know!