Auth0 Home Blog Docs

ionic2 signup issue popup

ionic2

#1

After a successfull signup with lock I get a blank popup that covers all the screen.

I have downloaded the demo app and works fine, I have even tried copying the dependencies to my project but still breaks.

Please help.
package.json

    "@angular/common": "2.4.4",
    "@angular/compiler": "2.4.4",
    "@angular/compiler-cli": "2.4.4",
    "@angular/core": "2.4.4",
    "@angular/forms": "2.4.4",
    "@angular/http": "2.4.4",
    "@angular/platform-browser": "2.4.4",
    "@angular/platform-browser-dynamic": "2.4.4",
    "@angular/platform-server": "2.4.4",
    "@ionic-native/app-availability": "3.6.0",
    "@ionic/storage": "1.1.6",
    "@ngx-translate/core": "6.0.1",
    "@ngx-translate/http-loader": "0.0.3",
    "angular2-jwt": "0.1.27",
    "angular2-moment": "1.2.0",
    "auth0-lock": "10.15.0",
    "canvas-text-wrapper": "^0.9.3",
    "install": "^0.9.5",
    "ionic-angular": "2.0.0-rc.3",
    "ionic-img-viewer": "1.2.1",
    "ionic-native": "2.2.3",
    "ionic2-rating": "1.2.0",
    "ionicons": "3.0.0",
    "ng2-color-picker": "1.1.0",
    "ng2-translate": "5.0.0",
    "npm": "4.5.0",
    "rxjs": "5.0.0-beta.12",
    "zone.js": "0.6.26"

cli:

Cordova CLI: 6.5.0
Ionic Framework Version: 2.0.0-rc.3
Ionic CLI Version: 2.2.2
Ionic App Lib Version: 2.2.1
Ionic App Scripts Version: 1.1.4
ios-deploy version: 1.9.0
ios-sim version: 5.0.13
OS: macOS Sierra
Node Version: v7.2.1
Xcode version: Xcode 8.3.2 Build version 8E2002

![alt text][1]


#2

This is my lock

  lock = new Auth0Lock('KEY', 'DOMAIN', {
    auth: {
      sso: false,
      params: {
        scope: 'openid email'
      },
    },
    theme: {
      primaryColor: "#7bb32e"
    },
    closable: false,
    languageDictionary:{
      title:"",
    }
  });

tried with redirect: true and same issue.


#3

Well this is funny.
I removed inappbrowser from the plugins and it started working, is this a good practice? documentation says it needs to be installed.


#4

I have the same issue - I find Auth0 very flaky with Ionic2 apps - every version upgrade there is a new bug. The latest is that on signup I get the blank screen with a “Done” button and have to close a blank screen. I need the InappBrowser for other things so I cannot uninstall that…


#5