Incorrect Compare Plans on Upgrade Screen

I am working on a Proof-Of-Concept (POC) Auth0 as the IdP for a client of mine. Because of that I’ve been using the free-tier. We are just about ready to upgrade to one of the new plans. I wanted to first POC integration with SSO (SAML) utilizing Auth0 as the Service Provider and letting customers bring their own SAML IdP.

I was looking through to find the most economical plan to upgrade to while we work out the POC to see if it is even an option we want to pursue. I thought I found a good option but it looks like the UI has just not updated with the new plans. I am not sure what plan it is even trying to reference.

Going: https://manage.auth0.com/dashboard/us//tenant/billing/subscription

I see this:

I’m assuming that the most economical plan for me to POC SSO/SAML stuff is the B2B – Essentials as it provides up to 3 Enterprise connections, and the mysterious B2E – Essentials does not exist? I’m guessing this B2E plan use to exist before Okta purchased Auth0 and renamed all the subscription plans. If it doesn’t actually exist it may be good to remove it as the default for that dropdown as it is quite confusing.

1 Like

Hi @davidhouseknechtdev,

Thank you for sharing this feedback! The plans did recently change, and the B2C, B2B, and B2E use case options refer to:

  • B2C (Choose to authenticate regular users via methods such as UN/PW or Social Connections)
  • B2B (Choose to authenticate your business partners via connections such as SAML, LDAP or AD)
  • B2E (Choose to authenticate employees)

It looks like the dropdown on the table has B2E selected when you first open subscriptions, but I believe this option should only be available in the dropdown when the B2E use case is selected on the top. You can view the B2C options by clicking the dropdown:

I’ll relay this issue to the appropriate team. You can also reach out to the sales team to get further clarification on plans:

https://auth0.com/contact-us

Thank you again for letting us know!

This issue has been added to the backlog to fix. Thanks again for reporting!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.