I lost the prompt for permission of using user's email somehow :( and struggling to find why

I delete all users in auth0 dashboard. My redirect url which I can copy/paste in is


but the prompt from auth0 no longer asks the user for access to his email so I am very confused what I changed that broke that. Instead, I just read →

“Log in to thewhitelister-dev to continue to SpamFilter.” Button: “Continue with Google”, then I login and nothing ever asks for permission and access to the users gmail account.

I also have tried adding gmail scopes as well such as

"https://www.googleapis.com/auth/gmail.send " +
"https://www.googleapis.com/auth/gmail.labels "+
"https://www.googleapis.com/auth/gmail.readonly " +
“openid profile email phone”,

I had also done it with just openid profile email phone though I need a google access token for those other scopes to work with the gmail api on the user’s behalf.

What am I missing here? (I am sooooo close to being done with the aut0 integration and onto the gmail piece so pretty excited to get this thing done).

I am finally stumped on this one. I found some checkboxes to enable Gmail and Contacts in the Authentication → social → google-oauth2 and now upon logging in I get a fun

This app is blocked

This app tried to access sensitive info in your Google Account. To keep your account safe, Google blocked this access.

Well, I was getting some prompt early on access to email but decided to proceed and say ‘screw it’ and now I get a much better one for some reason(no idea why) AFTER wiring up the real GCP client id and client secret (go figure!! no idea why but progress now).