How to troubleshoot a broken my application? Access Denied for all users on an app

I’m a n00b

I created a new app, basic login using Rails. I followed the quickstart. It worked. Then it stopped working. All users began getting OAuth2::Error (access_denied: Unauthorized
I get the callback after login all right, but the error comes on the post to oauth/token.

I assumed I had broken something. After much auditing, I created a new application in Auth0, changed out the credentials, and things worked. Change the credentials back to the first app, and they are broken.

So I have a working Rails app, but it seems a broken Auth0 application. I’ve looked through all the settings and it seems identical to the new app I’ve created 2nd (but we can never rule out human error).

My question is, how I can I troubleshoot what’s wrong with my Auth0 application? I know that switching to a new app works, so I believe something is broken or misconfigured on the Auth0 side. I just have no idea how to go about troubleshooting this. Clearing client-side settings also seems challenging – logging out and logging in doesn’t force through the login prompt again, so I’m stuck using incognito a lot.

Thanks for any advice and suggestions.

New to Auth0 that is. Not to Rails or Auth in general

Hi @john25

Are you checking the Auth0 tenant logs? That is the place to start. It is in your dashboard.