How to omit the prompt parameter?


I’m trying to connect to Canvas - which implements LTI 1.3. Canvas supports oauth2 based connections - however I’m getting the following error.

“prompt must be "none" (or omitted)”

It looks like Auth0 will send prompt=login. Is there a way to tell Auth0 not to send the prompt parameter? I can change the value to “none” using upstream_params, but that causes other issues. I really need to just omit that value.


I believe that if prompt is not included in the authorization request to the tenant itself it will also not be sent to the upstream identity provider.

Are you by any chance testing this using the try option in the dashboard? The try options in the dashboard include prompt=login in the request to the tenant itself so this would then be sent upstream.

In conclusion, if the real production application does not need to send prompt in the request to Auth0 this could become a non-issue.