Skip authorization if session already exists

Hello, I’m new to Auth0 and still trying to figure my way around. I created an application with a custom social connection. Every time I use the URL with the connection parameter, it redirects me to the social connection’s oauth authorization end point even though I already have an active session. Is there a way to skip the authorization if the user has already done so earlier?

Another question, I would like to have the application use a social connection by default when no connection parameter is specified and not show the auth0 login page with the various login options? Is that doable?

Hi @sowmya.mohan,

Welcome to the Auth0 Community!

It sounds like the fix is probably to set prompt: none in the /authorize request and I’ve added a link to the Silent Authentication docs below for more information on how that works:

I have a feeling that the Silent Auth docs and specifically prompt: none might answer at least part of your second question but please let me know if that’s not the case and I’ll be happy to further assist.

I hope this helps!


Hi @matt.g ,
Thank you for your response. Unfortunately it doesn’t look like the custom oauth provider I’m using supports the prompt:none feature. Is there any configuration that can be done on Auth0’s end to skip hitting the authorization end point if a session is already active?