Auth0 Home Blog Docs

Prompting confirmation despite prompt set to none

sdk

#1

Even when we add prompt: ‘none’ to constructor, there is an Auth0 authorization page that sometimes appear (first time a new phone is signing in).

this.set(‘webAuth’, new
auth0.WebAuth({
domain,
clientID,
redirectUri,
prompt: ‘none’,
scope: ‘openid profile’,
audience: https://${domain}/userinfo,
responseType: ‘token’
}));

Why is that? should we use connection_scope instead? Why?


#2

The prompt parameter is not listed as one of the parameters you can pass when initializing the Auth0.js instance so it’s probably not having any impact on how the request is performed; hence the behavior you’re seeing.

The Auth0.js library has a special-purpose method renewAuth for doing silent authentication, although, I believe the prompt parameter will also be accepted in the authorize method given that method calls into the /authorize endpoint which is the one supporting silent authentication.

You should update your usage to either use renewAuth or consider passing the parameter into the authorize method.


#3

Actually, the problem was that I was in development and setting the redirectUri to http://localhost. It always prompt with localhost.

Answer was found at https://community.auth0.com/questions/286/how-do-i-skip-the-consent-page-for-my-api-authoriz


#4