How can i hide "rememberBrowserCheckbox" for 30 days for not sending SMS for MFA during each login

I am using the default “mfa-widget” for the MFA UI : Auth0MFAWidget. Is it possible to hide checkbox :rememberBrowser? If not can i set default value : checked?
Because users are missing this checkbox and should authenticate with SMS code each login.

Hi, @lev.kogan thanks for reaching out and welcome to the Auth0 Community! :tada:

Have you looked into using our Rules to force this behavior?

This would involve setting the allowRememberBrowser value set to false so the user will always be prompted for MFA.

Let me know if this helps!

Best Regards,
Colin

Hi @colin.coutts. I would like to set allowRememberBrowser value set to true. I need that user will MFA once in 30 days. But on the popup of MFA exist checkbox called: rememberToBrowser. I would like this checkbox will be checked by default in case that allowRememberBrowservalue set totrue`.

Hi @lev.kogan,

Unfortunately, we can’t render the ‘remember browser’ checkbox to be prefilled. This is an option the user must opt into explicitly so they won’t be prompted for 30 days. I believe this use-case has been mentioned previously, I’d highly recommend filing a feature request to have this looked into by our Product Managers. We’re always looking for ways to improve our product so we’d appreciate any insights you’d like to add.

Best Regards,
Colin