Auth0 Home Blog Docs

Having trouble enabling Allow Offline Access

Hi
I am trying to enable Allow Offline Access in order to start configuring refresh token however when I log into my dashboard > APIs > settings I don’t see an option to enable that. Any help is much appreciated

.

Hey there!

Have you followed those steps?

Open your Dashboard and go to APIs using the left hand menu.
Click on the API for which you want to allow apps to get refresh tokens.
Scroll down at the Settings page, the Allow Offline Access toggle should be there.

Hi!

The issue here is that you are using the management API. It is not possible to get refresh tokens for the Management API, so therefore there is no “Offline Access” to enable in the settings. You will instead need to create a new token each time, which can be done programmatically by following the steps here: https://auth0.com/docs/api/management/v2/get-access-tokens-for-production

Other APIs have refresh tokens / enable Offline access, but the management API does not because it only support client credentials grant.

Thank you for your answer. It totally makes sense.

Let us know if you have any other questions!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.