/outh/token api missing refresh_token

I am not able to get refresh token in the response of /oauth/token end point. Any help is appreciated.

Hi @deepakkumar.shinde,

Are being sure to request the offline_access scope?

Take a look at this doc for more information:

Hope this helps!


I tried the api call with scope=offline_access but still not getting the refresh token in response.
I did some searsing on internet and came to know that Allow Offline Access switch need to be enabled for this. But I did not find this option in setting of API.

Open your Dashboard and go to APIs using the left hand menu.
Click on the API for which you want to allow apps to get refresh tokens.
Scroll down at the Settings page, the Allow Offline Access toggle should be there.

Hi @deepakkumar.shinde

Can you DM me the name of your tenant? In addition, I hid the screen cap you posted because it contained your client secret. You will want to rotate the client secret ASAP.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.