Github example not working

I am trying to get started with Auth0.

I tried the manual steps first - was not successful. So I tried the github example. (I did log into my tenant before creating the github download).

So I unzip the download (I’m using centOS 7.9). cd 01-login and run npm install- this works.
The npm start does not. Here is the log.
throw er; // Unhandled ‘error’ event

Error: listen EADDRINUSE: address already in use :::3000
at Server.setupListenHandle [as _listen2] (net.js:1320:16)
at listenInCluster (net.js:1368:12)
at Server.listen (net.js:1454:7)
at Function.listen (/var/www/html/01-login/node_modules/express/lib/application.js:618:24)
at Object. (/var/www/html/01-login/bin/www:4:5)
at Module._compile (internal/modules/cjs/loader.js:1085:14)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1114:10)
at Module.load (internal/modules/cjs/loader.js:950:32)
at Function.Module._load (internal/modules/cjs/loader.js:790:14)
at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:76:12)
Emitted ‘error’ event on Server instance at:
at emitErrorNT (net.js:1347:8)
at processTicksAndRejections (internal/process/task_queues.js:82:21) {
errno: -98,
syscall: ‘listen’,
address: ‘::’,
port: 3000
npm ERR! errno 1
npm ERR! 01-login@1.0.0 start: node bin/www
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the 01-login@1.0.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

Then the /root log is:
0 info it worked if it ends with ok
1 verbose cli [ ‘/usr/bin/node’, ‘/usr/bin/npm’, ‘start’ ]
2 info using npm@6.14.13
3 info using node@v14.17.1
4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
5 info lifecycle 01-login@1.0.0~prestart: 01-login@1.0.0
6 info lifecycle 01-login@1.0.0~start: 01-login@1.0.0
7 verbose lifecycle 01-login@1.0.0~start: unsafe-perm in lifecycle true
8 verbose lifecycle 01-login@1.0.0~start: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/var/www/html/01-login/node_modules/.bin:/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/usr/local/bin:/sbin:/bin:/usr/sbin:/home/silentm/bin:/root/bin
9 verbose lifecycle 01-login@1.0.0~start: CWD: /var/www/html/01-login
10 silly lifecycle 01-login@1.0.0~start: Args: [ ‘-c’, ‘node bin/www’ ]
11 silly lifecycle 01-login@1.0.0~start: Returned: code: 1 signal: null
12 info lifecycle 01-login@1.0.0~start: Failed to exec start script
13 verbose stack Error: 01-login@1.0.0 start: node bin/www
13 verbose stack Exit status 1
13 verbose stack at EventEmitter. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
13 verbose stack at EventEmitter.emit (events.js:375:28)
13 verbose stack at ChildProcess. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
13 verbose stack at ChildProcess.emit (events.js:375:28)
13 verbose stack at maybeClose (internal/child_process.js:1055:16)
13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:288:5)
14 verbose pkgid 01-login@1.0.0
15 verbose cwd /var/www/html/01-login
16 verbose Linux 3.10.0-1160.31.1.el7.x86_64
17 verbose argv “/usr/bin/node” “/usr/bin/npm” “start”
18 verbose node v14.17.1
19 verbose npm v6.14.13
20 error code ELIFECYCLE
21 error errno 1
22 error 01-login@1.0.0 start: node bin/www
22 error Exit status 1
23 error Failed at the 01-login@1.0.0 start script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 1, true ]

What do I do with that ?


Sorry there was a process running using port 3000. I stopped it and it now runs and give me the
Server running on port 3000.