Getaddrinfo ENOTFOUND https://www.vividcommerce.io:587

I have added SMTP as custom email service provider but it is throwing above error, I have checked the credentials that are fine http://prntscr.com/opz685, but email is still not sending.

Have you tried removing https:// part as that should not be included in hostname fields?

no,let me try wait a minute.

Tried test email sent successfully, but on real time signup it is throwing this error http://prntscr.com/oq01nq.

Are you sure that the smtp server is www.vividcommerce.io (especially www.) and not something else, like mail.vividcommerce.io or smtp.vividcommerce.io ?

There is no open SMTP port on www.vividcommerce.io (nor on vividcommerce.io).

So what I should do?

Find out the correct smtp server. Do you own this domain (mailserver), are you the domain / system administrator?

Actually I’m using these creds on my project and it is working fine.
port: 587
domain vividcommerce.io,
host: https://www.vividcommerce.io
So what are you saying is not possible I think because if these are wrong then it shouldn’t work on my production environment too.

Thanks, my server address was wrong.

1 Like

Try vividcommerce.io without the www and without the https://.

However, either a port scan or telnet test should show if there’s an SMTP server running or not.

nmap vividcommerce.io

telnet vividcommerce.io 587

Is it working now, without the www?

No, the address was totally wrong.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.