Auth0 Home Blog Docs

Get sample data with stream analytics



Hello All,

I am using continuous export and stream analytics for a Power BI report. But I have some problems configuring the inputs for stream analytics.

Continuous export writes data to a blob storage.

But when I click on “sample data” I got the error message:

“No events were found in ‘input’ for the specified time range”.

But I am sure there is data stored for this time range.

My path prefix pattern looks like:

application insights resource_keywithoutdashes/Requests/{date}/{time}

My application insights resource has a whitespace and I have everything in lowercases.

I followed these steps:|Qlikview BI

When I inspect the blob where the data is stored I see the container named “stats”. This container has a folder named “application insights resource_keywithoutdashes” and this folder has a folder Requests, in that folder there are folders for every day since I started Continuous export. This folders are named like “2016-10-04” and these have folders named 00, 01, 02 to 23.

I tried to change the path prefix pattern to “stats/application insights resource_keywithoutdashes/Requests/{date}/{time}” but then I got the error message: “Failed to sample data from ‘export-input’.” and in the details i got: “Operation Failed Unexpectedly. Activity Id: ‘xxx’”.

When I click test connection I always get the message “Successfully connected to ‘input’”

Why can’t I get sample data? What am I doing wrong? Do I miss something? Does anyone has some tips about how to configure this settings?