Auth0 Home Blog Docs

Get email address in SAML NameID

saml
#1

Hello

I want a user’s email address to appear in the SAML NameID field. However, the default value for this seems to be the Auth0 ID. How do I change it?

I’ve tried the following SAML settings but it doesn’t affect this at all:

{
  "mappings": {
    "user_id": "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/emailaddress"
  },
  "nameIdentifierFormat": "urn:oasis:names:tc:SAML:1.1:nameid-format:emailAddress"
}