Auth0 as SAML identity provider - how change NameID that auth0 provides to avoid pipe character?

The SAML NameId value is coming in as "user_id: “auth0|644c0bc8f1874ef6d339fb34” Our application won’t allow | characters to be part of the NameId. How do I change the username to not include the | character?

I think you can use a rule to modify the value of your user_id in the SAML assertion. The downside is that rules are deprecated and will cease to be available on november, 2024. Using a “Change SAML configuration” is the best option at the time: either you map another value on the nameId, or you transform it with a string function in the rule. Doing this implies you migrate the rule into an Action sooner or later. Is this of any help ?