Auth0 Home Blog Docs

Facebook Login web page does not redirect to the application at the first login

login
facebook
redirect

#1

Hi,

I am using Rails, I followed all the tutorials and configured lock with my callback, domain and everything. When I log in with email and password the redirects work fine, but when I try to log in with Facebook, after I click “continue as…” in the their login page I get redirected to my https://www.facebook.com/#= instead of my website.

Thanks

** I have already set my Valid OAuth redirect URIs in my Facebook app’s dashboard


#2

Can you please ensure you have done the following:
https://auth0.com/forum/t/how-to-get-facebook-logout-redirect-working/2678


#3

I got the same problem, i did the way the site says:

https://miinga.auth0.com/v2/logout?federated&returnTo=https%3A%2F%2Fmiinga.auth0.com%2Flogout%3FreturnTo%3Dhttp%3A%2F%2Flocalhost%3A8000&client_id=MY_SECRET_CLIENT_ID&access_token=[facebook access_token]

Redirect to facebook, but not redirect after that to my site. If i enter again the same url, redirect directly to my site and when i login again, ask for my user and password and thats ok. What is the problem?


#4

I got the same problem, i did the way the site says:

https://miinga.auth0.com/v2/logout?federated&returnTo=https%3A%2F%2Fmiinga.auth0.com%2Flogout%3FreturnTo%3Dhttp%3A%2F%2Flocalhost%3A8000&client_id=MY_SECRET_CLIENT_ID&access_token=[facebook access_token]

Redirect to facebook, but not redirect after that to my site. If i enter again the same url, redirect directly to my site and when i login again, ask for my user and password and thats ok. What is the problem?


#5