Overview
This article troubleshoots the error below that occurs while attempting to log in using the Facebook social connection when it has been installed via the Auth0 Marketplace:
App not active: This app is not accessible right now, and the app developer is aware of the issue. You will be able to log in when the app is reactivated.
Applies To
- App not active error
Cause
This error can occur for any of the following reasons:
- The Facebook app is in Development Mode
- Apps not set to ‘Live’ status on the Facebook Developer portal restrict logins to users with specific roles (Admin, Developer, Tester).
- The testing user lacks the required role
- When the app is in Development Mode, the Facebook account used for testing must be explicitly added as an Admin, Developer, or Tester within the app’s settings on the Facebook developer account.
- Business verification requirements are not met
- Using the Facebook social connection from Auth0 Marketplace does not bypass Facebook’s underlying requirement for certain types of applications to be associated with a legally registered business. This requirement originates from Facebook and applies to the app owner/developer, not necessarily the end-users logging in. If the requirement is not met, the errors related to this business verification requirement will occur whether login happens directly on Facebook or via the Auth0 connection.
Solution
Resolving this involves confirming the correct configuration of the following settings and access levels:
- The Facebook app is in Development Mode
- In the Facebook developer console, select the App.
- In Settings > Basic, switch the In Development toggle to Live.
- The testing user lacks the required role
- In the Facebook developer console, select the App.
- Navigate to Select App Roles > Roles > add the particular user as administrator or developer.
- Business verification requirements are not met
- Facebook may require the business owning the app to complete Business Verification for certain app types or permissions, and this process has not been completed.
NOTE: Reach out to Meta’s (Facebook) official support for assistance in configuring the social connection in the Facebook Developer account.