Error when trying to authenticate in Android 11 (multiple devices tested)

I have an Android app with a standard mobile login flow. When using an AVD (emulated device) on Android 10, everything works fine, but when deploying a device using Android 11 I get the following error message description from the Auth0 login request:

No Browser application installed to perform web authentication.

The status code is 0 and the response “code” is “a0.browser_not_available.” I’ve also tested it on three different Android phones with two different Android versions and it appears to only be happening in Android 11. Android 10 seems to work correctly. Additionally, I know that it was working the last time I tested it on an Android physical device, about a month ago, which coincides pretty well with the release of Android 11 on Pixel devices (the two Android 11 devices I tested were both Pixels) on September 8th. I also did a test on an AVD using Android R (11) API level 30 and got the same error.

To me it seems clear there’s some issue with mobile authentication in Android 11. Is anyone aware of this at Auth0, or has anyone else encountered this issue? I haven’t found any trace of this issue being raised anywhere.

Hi @adammtlx,

I am not seeing any support tickets reporting this same error or anything similar in the last month or so (since android 11). This suggests this isn’t a widespread sdk or platform issue. It sounds like a local issue.

I did some digging and it seems to be related to the version of the Auth0 library I was using. I was using 1.25.0, and upon moving to 1.28.0 (as well as updating a few other things), login started to work correctly again. Thanks for looking into it! It helped me to know it was something on my end.

Glad you were able to find a resolution! Thanks for the update :smile: