Error: The connection is not enabled


We have a Single Page Application in Auth0 that is connected to an OIDC Enterprise connection. Let’s call it VER2.
The VER2 connection is against a national identity provider. This identity provider has a new endpoint.
We created a new Enterprise connection called “NEW” with the correct new configuration.

When testing the connection “NEW” using the “Try” button, it works fine. We now change the Application to use the connection “NEW” instead of “VER2”.

When testing from the application we get an error message. Under the monitoring logs we see the message “Failed login” with description “the connection is not enabled” and the connection parameter is “VER2”. Even though we do not have this connection active anymore with this application, but instead the “NEW” connection.

Why does the application insist to use the old connection? We can not find any trace of the old connection connected to this application (except in the log file).

Hi @knut.aavatsmark,

Welcome to the Auth0 Community!

This error usually means that you have not enabled the connection in the application settings. Please confirm that the applications that is making the request has the correct client ID and the connection is toggled on in the applications connections settings.

Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.