Auth0 Home Blog Docs

Error parsing token: token contains an invalid number of segments

Having big trouble with this error. I’m developing in golang on my mac localhost. When I log in, seems to work.
Here is the callback response from auth0 that apparently does not have enough token segments. No idea why the token is wrong and what to do about it.
Help would be greatly appreciated!

http://localhost:3000/callback#access_token=MkDgUoi9hGg9rWRLr-SCMqsnisp_n8TB&expires_in=7200&token_type=Bearer&state=9Qmz-FBmu4RRe~Cj_9_E.LSrpsR0tr.g&id_token=eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiIsImtpZCI6Ik5VWTNOelEwUVRReU5UTXdPVE0yTnpRMU0wWTBRall3TlRRelJrTTFNelpCTUVaRlJqazRPQSJ9.eyJuaWNrbmFtZSI6InNoZWwiLCJuYW1lIjoic2hlbEBkcmVhbXJlYWx0eS5jb20iLCJwaWN0dXJlIjoiaHR0cHM6Ly9zLmdyYXZhdGFyLmNvbS9hdmF0YXIvNjQ3ZjI2MTg4NTFhNTlkMThiYWQxOGVhYTYyM2Y4MTE_cz00ODAmcj1wZyZkPWh0dHBzJTNBJTJGJTJGY2RuLmF1dGgwLmNvbSUyRmF2YXRhcnMlMkZzaC5wbmciLCJ1cGRhdGVkX2F0IjoiMjAxOS0xMC0wM1QxMjowNDozNi4zNTFaIiwiaXNzIjoiaHR0cHM6Ly9zZ29sZGJlcmcuYXV0aDAuY29tLyIsInN1YiI6ImF1dGgwfDVkOTNmZTI5ZjNlNzI3MGM0ZTI0NGVjYiIsImF1ZCI6ImNicVA0eGFTM2ZaUGdkM0tWSDJUdzRIaVZhcm9TRDF4IiwiaWF0IjoxNTcwMTA0Mjc2LCJleHAiOjE1NzAxNDAyNzYsImF0X2hhc2giOiJ5QllsS2EwMFNyT09FNFhPWGxlejBBIiwibm9uY2UiOiJxWTVGUG4xOGU4cHpxa1JTNjBoQzB4RFhGRzNCbEU3MCJ9.rVJ-dkdk2mB5DXgO0bdWT1oa9OOIeDpiJbjf4YKhHW0_qGnuKLknU9-nfO9gqbwW14pVGdCYAQsLhpzHLBxsu2s5CPyr_m1Phc3FgjDixGzvGkVtq0F07arEEY7Y_BjgsOENj7sOB5UXHiUPYYwJjWHy5oFzhG7tXvhtoya20qZ1ddvABNClsnGRlAAtG7geUAuiB09AJB78cBExfDv9RPjCOaBJ-y-h4W14P9-KFJuNBRTOEGnNXkV9EiQD7_X1TJz0yEoH8gzt2XsNVRZwATAefQDqgqyKPi_xkJkL4WH0e3ik_b2nKnU5ehS3AnBlszgxJKIQoBx4_rUIRnJucw