Error: Auth0 Dashboard -> Applications -> Save changes (refresh token) error

Hello there,

yesterday (04-June-20) I run into the following error when trying to save my changes in
manage.auth0.com/dashboard/us/<TENANT-NAME>/applications
I’m an admin to all applications in the tenant and here’s what I’ve tried to get around this:

  • log out -> log in
  • deleting cookies and local storage
  • log in trough incognito
  • log in with another browser (tried Chrome and Safari)
  • have another admin remove me from the tenant and invite me again

The rest of the application admins in the tenant are not having this issue.
I’ve searched the community here and couldn’t find anything close to this.
What can I do to solve this problem?

Error! Payload validation error: 'Missing required property: expiration_type' on property refresh_token (Refresh token configuration). (also) Payload validation error: 'Missing required property: rotation_type' on property refresh_token (Refresh token configuration).

1 Like

Possibly a bug in the UI? One of the two refresh token rotation options (Non-Rotating or Rotating) should be selected, but neither one appears to be selected in your screenshot. Non-Rotating should be highlighted by default.

2 Likes

Thanks for the think MarkD, I had exactly the same issue and I didn’t consider that button, I did not think.
It appears they’ve added this option and the form errors if it wasn’t previously set which gives the behaviour of “cannot edit applications until the user engages with the new feature we’ve added”.
To someone not considering pressing new buttons (e.g. “I don’t want to change smth I don’t know about”) its becomes a critical blocker.

1 Like

Thank you, @markd and @simon.tamman! I picked an option and it’s ok now.

You are both right about all you said- I didn’t even notice that “Refresh Token Behavior” option in the form. I just went there to make a change in some of the fields at the top. After seeing the error I somehow levelled myself that it’s about some refresh token on the user I’m currently logged in, but not some field in the form.

This can still be considered a UI bug as @markd mentioned. Telling the user By default, this is set to the non-rotating behavior turns out to be misleading.

Definitely looks like a bug to me. I looked at some of my oldest apps in my oldest tenants and they have all defaulted to non-rotating without me needing to do anything, which obviously didn’t happen in your case. Glad it’s fixed!

It might be possible that interacting with other areas of the UI or accidentally clicking on the screen during a scroll might somehow deselect it. It might be possible we are accidentally genuinely deselecting it as well (would that be clicking on it if it is selected?).
Arguably the issue here is that it being deselected is a valid UI state.