Enterprise Connection "Save Changes" Button Does Not Work

Overview

When navigating to the AD Enterprise connection settings in the Dashboard UI and trying to change the settings, clicking Save Changes does not work. When making a GET connection by id through the Management API, the connection options object returned includes an icon_url field. When inspecting the Network tab when clicking the button, no request is being made.

Applies To

  • Connection settings
  • Save Changes button
  • Management API

Cause

The “icon_url” is a connection setting that can only be managed via the Management API. The Dashboard UI currently does not allow for this field, so the UI validation is failing silently because there is no field in the UI for “icon_url”.

Solution

Engineering currently has a backlog item to fix this incorrect behavior.

In the meantime, the solution is to remove the “icon_url” field from the connection in order for the UI to work as expected.
This can only be done via the Management API by:

  1. Doing a GET to the get a connection by id endpoint
  2. Copy the returned “options” object and remove the “icon_url”
  3. Send only the new modified “options” object to update the same connection via a PATCH to the endpoint