ENOENT Error in the Authorization Extension

Hi, I am still using the Authorization Extension because of the group functionality. I have the following use case in my application:
When a new user signs up in our custom sign up page, in my backend, I send the data with POST /api/v2/users to create the new user in auth0. After that, I need to assign the user to a group in the authorization extension, so I use PATCH /groups/{group_id}/members with the newly created user_id of the auth0 user in the body. This API call returns (not always but quite often) the following error:

    {
      "code": 500,
      "message": "Failed to load code: ENOENT: no such file or directory, open '/data/io/node8/55e026dc-2433-43dd-b9c4-00f3f40ee293/webtask.js'",
      "error": "ENOENT: no such file or directory, open '/data/io/node8/55e026dc-2433-43dd-b9c4-00f3f40ee293/webtask.js'",
      "stack": "Error: ENOENT: no such file or directory, open '/data/io/node8/55e026dc-2433-43dd-b9c4-00f3f40ee293/webtask.js'"
    }

Also, when trying to access the authorization extension via the auth0 UI, I am getting the same error. The error is also appearing for other api calls such as GET /users/{user_id}/groups or DELETE /groups/{group_id}/members. Unfortunately, the error does not always appear, but quite often.

Things I tried out to solve the problem:

  • Adding a sleep of up to 20 sec after creating the user -> did not help
  • Retrying 20 times with 1 sec of sleep in between -> did somewhat help, but it is still unreliable and definitely to slow

I would appreciate any input on how to solve this issue. Thanks in advance!

We are having the same issue. this prevents us from logging in.
Once out of 10 tries we succeed.

Hey Folks!

Let me debug it with you. Can I ask you first to record me the HAR files of those unsuccessful flows and share them with me via DM? This way I’ll be able to inspect what is happening behind the scenes of the browser. Also it would be great if you can send me your tenant names via private message as well. Thanks!

Hey there Folks!

Have you had a chance to see my previous message?

Yep, thanks for the answer, but while trying to produce the HAR file, I was no longer able to reproduce the error.

I will continue to monitor it and if I get the error again, I will message you with the HAR file of the flow.

1 Like

Perfect! Thanks for letting me know!