Auth0 Home Blog Docs

Authorization Extension error with non-existent group members


  1. Add a user to auth0
  2. Create a group in the authorization extension
  3. Add the user you created as a member to the group you created
  4. Delete the user from auth0
  5. Refresh the group page and notice the error message about a user not existing. Nothing can be done with any members of that group now. You cant even see who else is in the group.
  6. Make an api request to see the members of the group /api/groups/:groupId/members. Notice that you get a 400 error stating that a user does not exist.

There doesn’t appear to be a way to remove non-existent users as group members. I wouldn’t expect the entire group to become broken just because one member doesn’t exist anymore…
There was a similar issue last year (different error code returned, but same behavior) that was resolved, looks like a regression occurred somewhere between then and now.


Any update on this one?


I ran into this too!


Providing a summary on this situation as it seems this was communicated also through a different support channel and we did not provide an update here. There was an update to the extension logic to handle deleted users, so ensure that you’re using the latest version of extension; I tried it with 2.4 and could not reproduce the issue. Having said that if you still reproduce the issue with deleted users then please provide detailed information about the steps taken.


Any update on this one?


I ran into this too!