"Email Does Not Match any Enterprise Directory" Error on the Login Page

Overview

When attempting to login, after entering an email the login page returns the following error:

“Email does not match any enterprise directory”.

Applies To

  • Login Page
  • Enterprise Connection
  • Home Realm Discovery (HRD)
  • Identifier First
  • Organizations

Cause

This error will occur if any of the following conditions are met:

  • The Authentication Profile configured is Identifier First.
  • There are no Database connections enabled for the application.
  • The email domain entered does not match any Identity Provider domain configured for Home Realm Discovery for enterprise connections.

Solution

Complete the following steps to resolve this error:

  1. Go to the Dashboard > Authentication > Enterprise.
  2. Click on the intended enterprise connection.
  3. Go to the Login Experience Tab.
  4. To have the email domain entered automatically redirect the user to the identity provider through Home Realm Discovery, go to the Identity Provider domains field and add the intended email domain.
  5. Click Save.

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If the error persists after configuring HRD, the issue may be due to the application’s login type setting. In this case, perform one of the following actions:

  • Change the application’s login type from Business users to Individuals.
  • Enable the required enterprise connection for an organization.

Related References: