Do not enable m2m client for configured connections

Hi there,

I am creating a m2m client via REST API, using the POST /api/v2/clients endpoint.

I also have two auth0 connections configured (database connection and Azure AD enterprise connection).

After my m2m client gets created successfully, the client gets enabled for all my auth0 connections.

Is there a way to prevent my client to be enabled for those connections? I don’t need this behavior and I don’t want it because as a result I receive diffs in my terraform execution plan.

Thanks for your help :slight_smile:

Hello there @dominik.vogt welcome to the community!

You can create the client (all clients) without enabling it on connections by doing the following:

In the dashboard, Go to Manage → Settings → Advanced → Settings → Enable Application Connections. Toggling this setting to be off should get you what you’re looking for.

Hope this helps!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.