Enable Application Connections

Enable Application Connections.
found one major issue while creating multiple applications it enables all connections and that is the default behaviour of Auth0.
the problem was solved following this Application Connections
Now wants to disable this feature from terraform.

Hi @prathod,

Thanks for reaching out to the Auth0 Community!

I understand that you’ve observed a specific behavior when creating applications that enable all the database connections by default. Toggling the Enable Application Connections in your Tenant Advanced Settings will allow you to change this behavior as you have found.

Now, to disable this feature using terraform you’ll need to do something like the following:

resource "auth0_tenant" "tenant" {
   // redacted for brevity
   flags{
       enable_client_connections = false
   }
}

After doing so, new applications that a created will not enable all the current connections.

You may find the auth0 tenant Terraform docs useful: https://registry.terraform.io/providers/alexkappa/auth0/latest/docs/resources/tenant#flags

Please let me know if you have any further questions.

Thank you.

Hi @rueben.tiow thank you for your response yes i have implemented this resource and works fine and also i got my error resolve for applications making connections and every time showing changes on adding new application on terraform plan.

1 Like

Hi @prathod,

That sounds great, I’m happy to hear that it works now.

Please let me know if there’s anything else I can do to help.

Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.