Customize the 'Log in at' button

Hi,

I am trying to customize the ‘Log in at …’ button text but can’t seem to fully customize it. Screenshot attached. As you can see, it the button’s label is 'Log in at ab1e0336-a247-4…'

I read that the language dictionary param that controls this label is loginAtLabel and its default value is ‘Log in at %s’. I tried to change the value to simply 'Log in' but looks like the placeholder %s` can’t be removed and is eventually replaced the the Connection’s server name (ie, the ‘ab1e0336-a247-4…’ in the screenshot). I just want the label to say ‘Log in’ because the server name could confuse our users.

I also tried setting the labeledSubmitButton param of the Lock options object, but doesn’t seem to apply to the log in button I’m trying to change.

In summary:

  1. How do change the button’s label to simply ‘Log in’
  2. For informational purposes, where does auth0 pull the the value for the %s placeholder? I have two connections (ADFS and Microsoft Azure AD) and different values are used depending on the Connection used for each Application

Please advise.

thanks,
Steve

Hi @websupport,

Welcome to the Auth0 Community!

In my testing, I was not able to omit the %s. I’ll reach out to the team and see if I can find another solution.

It appears the Azure AD connection pulls it from the Microsoft Azure AD Domain field in the connection settings.

When I add an ADFS connection it doesn’t provide a login button with this label. Do you have any example of what that label looks like?

Hi @dan.woda ,

Thanks for your feedback.

  1. Thanks for looking into how to get rid of the %s placesholder
  2. I’m glad you also caught this oddity. I did notice that '‘ab1e0336-a247-4…’ comes from the Microsoft Azure AD’s Settings > Microsoft Azure AD Domain setting. I also do not know where the login button pulls the value for ADFS. Here is the screenshot. As you can see the value is ‘academyart.edu’:

Appreciate it and will keep an eye out for your feedback.

thanks,
Steve

hi @dan.woda , any updates on this?

thanks,
Steve

Hi @websupport,

I am still waiting to hear back, thanks for your patience on this!