Custom Text: different ${clientName} values on login and email-verification prompts

Hello there

I’m trying to customize the appearance of prompts like “login” and “email-verification”. Both prompts use ${clientName} variable.

However, in the case of “login”, clientName refers to the correct value. But in the case of “email-verification”, it renders “All Applications”.

Why are the values different?

Thank you for the reply. I have follow-up questions

Check if there are specific configuration settings for each prompt.

Where do I check this? This is all I see:

Ensure that both prompts are using the same template or source.

Same question. I don’t see any “template” or “source” settings for prompts. I use Universal Login with no custom templates.

Check if there are any differences in the data available when rendering the “login” versus the “email-verification” prompt.

How do I check this? I don’t have control over what Auth0 renders, except for text customization that doesn’t work well for me.

If possible, review the code or configuration responsible for rendering these prompts.

I appreciate your help, but honestly, this looks like a ChatGPT response. I can’t “debug” the Auth0 pages. I can look at the HTML response, but it’s no use. Could you please elaborate on the debugging part?

I haven’t resolved the issue yet.


Hey @serhii.holinei :wave:

How are you sending the emails to users to verify their emails?

Are you using the /api/v2/jobs/verification-email Management API endpoint?

If so, you may be seeing “All Applications” on the email-verification screen because you didn’t include the client_id parameter in the request.
Note that the doc states “if no value provided, the global Client ID will be used.”

I believe the same applies if you are using the /api/v2/tickets/email-verification Management API endpoint as well to generate the email verification ticket and send the email yourself.

Hey @gparascandolo

This was exactly it. Thank you for being so helpful. Now I don’t have to hardcode clientName.

1 Like

Glad to hear you got it resolved! :slight_smile:

1 Like