Problem statement
We have set up a custom domain. When trying to use it, we got an error screen. The Dashboard confirmed that the “Your domain is configured correctly” when clicking “Test” on the custom domain.
Symptoms
Error is thrown when the custom domain is used, and the request isn’t even making it to their Auth0 tenant.
Steps to reproduce
- Update the native app to use a custom domain
- Try and run the app locally using an emulator
Troubleshooting
The best way to diagnose this issue is to try making a request to /authorize using the custom domain outside the customer’s network.
Cause
The custom domain was blocked by the customer’s firewall/VPN configuration.
Solution
Add the custom domain to the firewall or VPN’s allowlist.