Custom Domain setup not working for auth0/auth0-spa-js

There could be a misconfiguration in the system or a service outage. We track these errors automatically, but if the problem persists feel free to contact us with this tracking id:

I’m trying to implement custom domains with auth0/auth0-spa-js.
I’ve followed all the instructions from the documentation provided.

Context:

  1. Using universal login with no custom login page
  2. Setting domain on the front end to the my approved custom domain login.superfitapp.com
  3. Setting backend jwt issuer to https://login.superfitapp.com/ (with the slash at the end)

I don’t know what else I am missing. My custom domain is managed by cloudflare and I set the CNAME ‘login’ to the correct address provided by auth0. What could I be missing?

1 Like

We are running into this exact same issue, and Auth0 support hasn’t identified the cause. This is causing real issues for us because without using a custom domain silent authorization is failing on a number of browsers. Could someone from the Auth0 team provide guidance?

1 Like

It’s the only reason I upgraded from my legacy plan! Any help would be appreciated!

1 Like