Custom DB not connecting: exceeding execution time

I am just testing the MS SQL connection from the get user script (Any script for that matter).
But every time I test it… the connection exceeds the time limits and throws webstack execution exceeded time limit.
I have checked the firewall in Azure sql. they are fine… I even added open IP range to allow all IP(just for test).
I still get the same error.
I know the error is happening only with connection as I have placed the logs appropriately.
TO ensure the there are no issues on the database side I users credentials of another database that is already in use successfully by another auth0 tenant. The issues is same with that as well.
The execution error is not there when I comment out the sql connection part.

1 Like

Hi @productmanager , thank you for describing your problem!

Does the custom db connection you are testing is enabled to at least 1 application registered in your Auth0 tenant?
You can check this:
Auth0 tenant-> Authentication -> Database -> your custom db -> Applications

In this case, I would also think about taking a closer look at your custom database scripts.

Please let us know if your were able to move forward with this!

Hi @productmanager,

Can you paste your custom-db source code here for review? Mask endpoints and credentials.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.