Continue with Google button not present on New Universal Login

Problem statement

We have an issue regarding the “New” experience of Universal Login. We migrated from “Classic” to “New”, and we noticed the action “Continue with Google” isn’t available anymore. Also, when using the “Try” button from the “Branding > Universal Login > Customization Options” Dashboard section, it does not reflect the actual page we currently have. In addition, the connection is correctly enabled for the application, but “Continue with Google” disappears when we switch the tenant from the classic experience to the new experience.


A network trace and a detail of the request to /authorize were reviewed.


There is more than one Auth0 database enabled for the same app and the “connection” parameter is in the request to /authorize. Sending that parameter is interpreted that the only connection you want to use is the one specified and restricts the others.


You should not add a connection parameter to the request to the /authorize endpoint. If you do, it will ONLY show that connection.

If you have 2 or more DBs enabled for the same app, New UL will choose the one set in the default directory to log the user. If there is only one DB (which is recommended), you should use that one.

If you don’t have any connection set in the default directory, the new UL will choose one.
You can use the default directory to force new UL to use that connection in cases where you have more than one DB for the same app.

The recommended would be not to use more than one DB per application, but if you need to do it without using the connection parameter because it breaks the Google button, the only option with the New UL is the default directory (see Tenant Settings).