Auth0 Home Blog Docs

Connection Strategy Not Supported

Hi, we’re attempting to use an Azure AD connector via Google Cloud Endpoints, but we’re getting this authentication error:

{
“date”: “2019-06-26T10:45:47.949Z”,
“type”: “fcoa”,
“description”: “Connection strategy not supported.”,
“connection_id”: “”,
“ip”: “x.x.x.x”,
“user_agent”: “Chrome 75.0.3770 / Windows 10.0.0”,
“details”: {
“body”: {
“client_id”: “x”,
“username”: “y”,
“password”: “*****”,
“realm”: “x”,
“credential_type”: “http://auth0.com/oauth/grant-type/password-realm
},
“qs”: {},
“connection”: null,
“error”: {
“message”: “Connection strategy not supported.”,
“oauthError”: “Connection strategy not supported.”,
“type”: “invalid_request”,
“uri”: null
},
“session_id”: “x”
},
“hostname”: “xxxx”,
“auth0_client”: {
“name”: “auth0.js”,
“version”: “9.8.2”
},
“log_id”: “90020190626104547950981356866089242581909538”,
“_id”: “90020190626104547950981356869389242581909538”,
“isMobile”: false
}

We’ve previously used a regular AD connector which worked fine. Azure AD is giving issues.

Thanks very much.

1 Like

I Also have the same problem and am passing exactly the same properties to Auth0. Works fine when setting realm as the default database created by Auth0 and login in with local users but when changing realm to the Azure connection name it fails with.

{
“error”: “invalid_request”,
“error_description”: “specified strategy does not support requested operation (undefined)”
}