Connection Refused only on Signup

Hi Auth0 Community,

I’ve been having trouble with “Signup” using “Database Connection”. I keep getting an “ECONNREFUSED” error but ONLY for signup and it doesn’t even hit my application so there were no logs.

Login works fine. Other testing I’ve tried is on the Database Action Scripts, I have tried using the “create” URL in my LOGIN script and surprisingly it works!! So I think the issue might be on auth0’s side

My setup is all in local. I have a login and signup endpoint in my application and exposed these using ngrok. The Database Action Scripts I wrote is just simply calling these endpoints. Emphasizing again that Login works but not Signup.

Hi @carlshippit ,

The error indicates that the connection was refused by your server when trying to look up existing users during signup.

Could you please whitelist the Auth0 IP addresses for inbound connections? You can find the list of IPs by navigating to Auth0 dashboard > Connections > Database > click on your connection name > Custom Database tab > scroll down to see a list of IPs.

Hope this helps!

Thanks @lihua.zhang for the reply. I will try that out but you mind checking on your end as well? The reason I’ve asked is because this only occurs when I’m testing the Signup but the Signin works nicely. I presume that both of these requests should be on the same IP right? So why do they behave differently?

Hi @carlshippit ,

I don’t have access to the backend logs. To check the backend details, we will need to open a support ticket. Do you need my help to create a ticket on your behalf?


Hi @lihua.zhang

I’m sorry that my reply came in a little late. Can you help me how to open a support ticket please?