Conflicting setter definitions for property "password": com.auth0.json.mgmt.users.User#setPassword(1 params)

Please include the following information in your post:

  • Which SDK this is regarding:
  • SDK Version: 1.44.1
  • Platform Version:
  • Code Snippets/Error Messages/Supporting Details/Screenshots: Caused by: com.fasterxml.jackson.databind.JsonMappingException: Conflicting setter definitions for property “password”: com.auth0.json.mgmt.users.User#setPassword(1 params) vs com.auth0.json.mgmt.users.User#setPassword(1 params)

I am getting the above error when trying to get a user with user id through Management API

Is this a feature request or bug report? If so, please create an issue directly in the corresponding GitHub repo. The Community SDK category is for general discussion and support.

1 Like

Hi @phajra ,

Welcome to the Auth0 Community!

Do you see the same error when trying the same user id via the Management API? And does this happen with some user ids or all user ids?

I found this thread regarding a similar error. I am not familiar with Jackson. Hopefully you can find something useful from the link.

I ran into this trouble today. Root cause was conflicting versions of the jackson jars. In my case, a somewhat older AWS S3 client was pulling in older jackson jars and Auth0’s library wanted a newer set. Updating the older S3 client helped by bringing the jackson jars it wanted closer to the version in Auth0’s dependencies.

Thank you @petercardona for sharing the root cause of your use case with us :+1:

Thank you for your response. Through Management API I am able to get user data. Let me check the Jackson issue.


Pradip Hajra

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.