Chrome and CORB

Hello,

I am using a custom Universal Login Page and have configured it to use my logo using a URL from my host. The logo shows correctly for FireFox and Samsung browser on my Android but when I use Chrome the image does not load and throws a CORB warning in the console. My host is listed under allowed Web Origins and since testing also under CORS.

Are there any additional settings or considerations to ensure the logo loads in Chrome?

Thank you,
-Ivan

Hi @iemunoz09,

Welcome to the Community!

Can you post the full error? I haven’t seen this behavior, and would like to narrow it down.

Hi @dan.woda ,

The full message that shows up in Chrome’s dev tools console is:
Cross-Origin Read Blocking (CORB) blocked cross-origin response https://juegagt.epizy.com/img/logo.png with MIME type text/html. See https://www.chromestatus.com/feature/5629709824032768 for more details.

If you navigate to https://juegagt.epizy.com, you should get re-directed to the Auth0 login page. When using Chrome, the logo does not show up and the console shows the message above. When using FireFox or other browsers, the logo shows up just fine.

Please let me know if there is any known solution or workaround for the image/logo to load in Chrome.

Thank you,
-Ivan

It looks like the image at https://juegagt.epizy.com/img/logo.png is returning with a content-type header of text/html, and it should be returning with image/png.

It randomly started working for me. Can you try it again?

I’m not sure what I can do about the content-type header since it’s just an image.

The image is still not loading and I have tested on both my laptop and phone.

I did encounter this article describing how to disable Chrome’s samesite cookie requirement; disabling this setting does load the image but Chrome’s default is to enable this setting so I’m hoping a different solution might exist.

Thank you

@iemunoz09,

Can you try hosting it on a different image service, just to confirm that the header is the issue?

Hosting the image on a different image service seems to work.

Does that mean I cannot link it to the image on my site’s host?

You just need to change the header it looks like. How are you hosting it?

I’m using InfinityFree to host my site.

Thank you for your insight, it looks like the content type is expected with my current hosting plan. I’ll consider using an image host as a workaround.

Cheers!

1 Like

Glad you figured it out! Cheers :beers: