Change response type of Auth0 authentication

Hi all,

I’m using Google Cloud Endpoint with OpenApi and Auth0 to apply authentication for my Endpoints based on instruction

After setup everything is work fine but, I just have one problem is:
If I use CURL command to test api without Bearer authorization -> I will get error code 401 and Json in body response.
But when I use Postman or another tool access my api without Bear authorization -> I get a response with HTML with error code 400 (bad request) miss Missing required parameter: response_type.

I don’t know how to fix that. I just want if I access my api which any tool I will get the same response code 401.

Can any body help.
Thanks

Same problem here when doing a redirect from my domain as I am testing my system for production.

Here is the error log (xxxxx used to redact info):

{
  "date": "2018-05-31T13:19:33.870Z",
  "type": "f",
  "description": "Missing required parameter: response_type",
  "connection_id": "",
  "ip": "xxxxxxxxxx",
  "user_agent": "Mozilla/5.0 (X11; CrOS x86_64 10452.96.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36",
  "details": {
    "body": {},
    "qs": {},
    "error": {
      "message": "Missing required parameter: response_type",
      "oauthError": "invalid_request",
      "type": "request-error"
    }
  },
  "hostname": "xxxxxxxxxxx",
  "log_id": "90020180531131933872614095380277365455736776015285846082"
}
1 Like

Although I have a different setup, I’m getting a similar response when I can clearly see the response type query parameter.

Hey there!

Sorry for such delay in response! We’re doing our best in providing the best developer support experience out there, but sometimes the number of incoming questions is just too big for our bandwidth. Sorry for such inconvenience!

Do you still require further assistance from us?