Can't use Azure AD with common endpoint

I’m trying to setup an Azure AD connection with Auth0. When I check “Use Common Endpoint”, save and come back to the settings, the option is disabled again. This was already mentioned here, and @kimcodes said it was probably a bug in the dashboard (not fixed yet, apparently).

I tried the suggested workaround, i.e. updating the connection manually using the management API, but it seems wrong. The suggested property useCommonEndpoint doesn’t follow the naming convention of other properties (they’re all using snake case); there is, however, a waad_common_endpoint, which was set to false, and I also tried setting it to true.

But whatever I tried, I’m unable to connect using an account from an Azure AD tenant other than my company’s. The email field only accepts “” as the domain. How am I supposed to make it work? I want users to be able to authenticate with any AzureAD tenant.

:wave: @tlevesque that is correct, I do not believe the issue is fixed yet. When you try to patch the connection with the useCommondEndpoint what happens?

This is definitely a bug in the UI. I used fiddler to capture the PATCH call to the Auth0 API when I saved the change in the UI. The useCommonEndpoint was not included in the payload. I then did a reissue + edit on the request in fiddler, adding in the useCommonEndpoint into the JSON payload and it saved correctly. Reloading the connection settings then correctly identifies that the common endpoint is enabled.

Hey there!

Sorry for such delay in response! We’re doing our best in providing the best developer support experience out there, but sometimes the number of incoming questions is just too big for our bandwidth. Sorry for such inconvenience!

Do you still require further assistance from us?