Auth0 Home Blog Docs

Can't sign in to extensions, No authorization token


#1

Since this morning I cannot sign in to either the “Real-time Webtask Logs” or the “GitHub Deployments” extensions, getting these errors:

{"error":"ArgumentError","message":"Must provide an id_token"}

UnauthorizedError: No authorization token was found
   at middleware (/data/_verquire/express-jwt/3.1.0/node_modules/express-jwt/lib/index.js:79:21)
   at Layer.handle [as handle_request] (/data/_verquire/express/4.12.4/node_modules/express/lib/router/layer.js:82:5)
   at next (/data/_verquire/express/4.12.4/node_modules/express/lib/router/route.js:110:13)
   at /data/_verquire/body-parser/1.12.4/node_modules/body-parser/lib/read.js:111:5
   at done (/data/_verquire/body-parser/1.12.4/node_modules/raw-body/index.js:248:14)
   at IncomingMessage.onEnd (/data/_verquire/body-parser/1.12.4/node_modules/raw-body/index.js:294:7)
   at IncomingMessage.g (events.js:260:16)
   at emitNone (events.js:72:20)
   at IncomingMessage.emit (events.js:166:7)
   at endReadableNT (_stream_readable.js:923:12)

What can I do?


#3

I was not able to reproduce the situation; tried with version 1.1 of the Real-time Webtask Logs extension so the situation may some require some very specific conditions to be triggered. You should try to access the extension in an incognito session to troubleshoot any issue with cookies and also a different browser; also ensure that you login with a user that is an administrator in the tenant for which the extension is being launched. If the situation persists it may also help if you can capture and share an HTTP trace of the full authentication attempt (be sure to redact passwords and other sensitive information before sharing the trace).


#4

Sorry, this actually solved few hours after the original post.

Can’t tell exactly what the issues was but it was solved after signing out and then signing in to Google, our ID provider.

(I tried to post another message saying this but you can’t post here unless another person replies. Also tried to edit the message, but apparently you can’t edit messages here just the subject line)


#5

No worries, thanks for the follow-up; I’ll chase the inability to update/reply internally as on a personal level I believe at least editing the message should be possible.