Can't customize logo in login popup with my new tenant

Hello,
I have discovered recently Auth0 and I’m exploring docs and experimenting code to fully grasp it.

My first React app worked fine but I dind’t like the tenant name (the default dev-xyz… assigned by Auth0 when you don’t choose a name). Since it’s not possible to rename the tenant I created a new one with a more meaningful name and I moved my web app into this new tenant.

Everything works (even customized login with multiple languages, customized colors, etc.) but I can’t manage to get a custom logo in the login popup… I assigned a custom logo both in my web app and in the universal login settings but the popup appears always with Auth0 logo. It was working fine in the old tenant…

this is the logo URL
https://i.imgur.com/wov22bB.png

I feel like I’m missing something trivial but I can’t understand what…

Can anyone kindly suggest me a solution?

Thanks

If you’re using the Classic Universal Login Page (ULP), and you have the customization toggle switched on under the Login tab (which I assume you have, otherwise you’d see your logo), make sure to adjust the default template like this:

  theme: {
    logo:            config.icon ? config.icon : 'https://cdn.auth0.com/styleguide/components/1.0.8/media/logos/img/badge.png',
    primaryColor:    colors.primary ? colors.primary : 'green'
  },

because by default the logo line (line 60) is commented out.

Thanks again Mathias
I just found it on my own 2 minutes ago. I used this

theme: {
        logo:            'https://i.imgur.com/wov22bB.png',
        primaryColor:    colors.primary ? colors.primary : 'green'
      },

I saved and now it works! :slight_smile:
Have a nice day

1 Like

Glad it worked, yes, that’s the hard-coded option :slight_smile:

If I can give a little suggestion to improve the docs:
it would be better to mention a note beside the custom logo settings in the universal login menu (in the dashboard)
The first time I used this menu and I swear it worked at 1st attempt , then with the new tenant it stopped working.
Newcomers might be confused if they do the same, a little note will speed up new adopter learning process.

1 Like

I don’t even know why that line is commented out by default. I’ll take that feedback internal.

I guess there is some mecahinsm that propagate the custom logo from dashboard setting into that line of code, but, probably if you modify the custom code as I did to experiment custom languages the above mechanism doesnt work anymore. Probably it detects the code is != from template and refuse to change it.
Now I rememeber the custom logo from menu worked before I touched the language
these are little improvements of course but you can save few hours to newcomers :wink:

I’m using the iOS native flow. Does this setting apply to me? I too don’t see a custom logo, although I have the right one showing in the dashboard.

If you’re using the iOS Native flow (embedded), then (I believe) the logo configuration doesn’t come from the logo configuration in the Auth0 dashboard, however I’m not familiar with the iOS SDK myself.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.