Auth0 Home Blog Docs

Can't connect to AWS postgres RDS custom database

Hi,

I created a postgres RDS in AWS as a custom database for my test tenant. I am able to connect to it using Postico (working on a mac). I’ve entered in the url for the connection string according to the Login and Get User template:

postgres://${configuration.user}:${configuration.pass}@..us-west-2.rds.amazonaws.com;

When I try to connect I get the following error:

{
“error”: “invalid_request”,
“error_description”: “the connection was disabled”
}

  1. How do I set the port number in the script
  2. Is there an IAM role that I need to create in my AWS account in order for the connection to work?
  3. I am attempting to migrate JSON from a different tenant (can import the file into the Auth0 database so I know the data format is correct. Do I need to have a users table in the database in order to import the data or will that table be created during the import process once I can connect?

Thank you,

Siggy

Hello @siggyt,

“the connection was disabled” usually means you haven’t enabled that connection for at least one application. Can you confirm you have enabled the connection for at least one app?

2 Likes

Hi,

I am still struggling to connect to the postgres RDS. I keep hitting the same error whether I am using encryted or unencrypted user and password:

[error] 28P01 - password authentication failed for user

Solved - I did not have ssh open in my security group for the RDS.

2 Likes

Perfect to hear that! Glad you have it working and thanks for sharing!

Hi Konrad,

Thank you - yes, I was very happy to see it working.

I did want to mention that I am not receiving a verification email when I try to add users. The user is getting adding to the database, but I am not getting an email. How might I fix that?

Thanks,

Siggy

Hey there @siggyt!

It seems that this issue is a bit off the topic here. Can you open a separate topic for that? It will . make the navigation and searchability clearer for all users. Thank you!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.