Auth0 Home Blog Docs

Cannot register in New Universal Login

I tried switching my account to use the New Universal Login flow, but when clicking Register I get this.

OpenIdConnectProtocolException: Message contains error: ‘invalid_request’, error_description: ‘The connection is not yet configured. Please go to the database connections and setup your Create script, or disable sign ups for the connection.’, error_uri: ‘error_uri is null’.

I do have a custom database, set for automatic migration, but obviously no create script necessary there.

Hey there @rev23dev, I wanted to touch base on this subject and confirmed you updated the default login route after switching over?

We’ve also seen this solution resolve that challenge in the past.

Please let us know if this doesn’t remove the hurdle for you so we can work more on this together. Thanks!

Hi James. I didn’t update any route… but this occurs even when using the Test button on the connection. I will take a look at the proposed solution, but this definitely seems like a bug.

I tried the following:

  1. Disabled the migrations setting on my database to get the other scripts to show
  2. Replaced the create script code with “return callback(null)”
  3. Turned migrations setting back on

This also did not work. In this scenario it told me it failed and that I may have clicked the back button (i did not)

Tried again with this method and suddenly that is working… I think. Will do more research. Still seems like a bug :wink:

1 Like

I will keep this topic open for two weeks just in case @rev23dev, thanks for the help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.